Troubleshooting Sitecore Index Errors : Index already exists

Greetings Reader,

In this post, I would like to address some of the commonly faced issues while setting up SOLR to work with Sitecore. This post specifically targets Sitecore 8,  but should be valid for some of the older versions

ERROR

An index with the name “sitecore_master_index” have already been added.

MasterIndex

REASON

The issue is that there is more than one index with the name “sitecore_master_index” being loaded on the sitecore application start.

SOLUTION

Scenario 1 : While using SOLR, all the lucene index files are not disabled properly

Please make in your App_Config/Include folder , that only one of the two files is enabled (depends upon if you are using lucene or solr) Sitecore.ContentSearch.Lucene.Index.Master.config or Sitecore.ContentSearch.Solr.Index.Master.config

Scenario 2 : Custom patched config files 

If you are using custom patched config files to add Index strategies  or add computed fields to existing indexes, please make sure that your patches are being applied in correct order.

if you are unsure about how patching works, this link can get you started

http://sitecore-community.github.io/docs/documentation/Sitecore%20Fundamentals/Patch%20Files/

Please comment below if you have questions or tweet me @sjain_hi

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: