Fix for index not found error while installing Commerce Connect 7.2

I found a missing step in the Sitecore Commerce Connect 7.2 Installation Guide that I’d like to share:

On step 5 of the “Integrating an External Commerce System – Creating a Product Repository” guide you are instructed to Synchronize All Products, however when I reached this step I received the following error:

SynchronizeError

Upon further inspection in the Sitecore log file, I found the following:

Exception: System.Reflection.TargetInvocationException
Message: Exception has been thrown by the target of an invocation.
Source: mscorlib
at System.RuntimeMethodHandle.InvokeMethod(Object target, Object[] arguments, Signature sig, Boolean constructor)
at System.Reflection.RuntimeMethodInfo.UnsafeInvokeInternal(Object obj, Object[] parameters, Object[] arguments)
at System.Reflection.RuntimeMethodInfo.Invoke(Object obj, BindingFlags invokeAttr, Binder binder, Object[] parameters, CultureInfo culture)
at System.Reflection.MethodBase.Invoke(Object obj, Object[] parameters)
at (Object , Object[] )
at Sitecore.Pipelines.CorePipeline.Run(PipelineArgs args)
at Sitecore.Jobs.Job.ThreadEntry(Object state)

Nested Exception

Exception: System.ArgumentException
Message: Index commerce_products_master_index was not found
Source: Sitecore.ContentSearch
at Sitecore.ContentSearch.ContentSearchManager.GetIndex(String name)
at Sitecore.Commerce.Data.Products.ProductRepository.GetEntityItems(Item repositoryItem)
at Sitecore.Commerce.Data.Products.ArtifactRepository`1.GetEntities(Item root)
at Sitecore.Commerce.Pipelines.Products.GetSitecoreProductList.GetSitecoreProductList.Process(ServicePipelineArgs args)
at (Object , Object[] )
at Sitecore.Pipelines.CorePipeline.Run(PipelineArgs args)
at (Object , Object[] )
at Sitecore.Pipelines.CorePipeline.Run(PipelineArgs args)
at Sitecore.Commerce.Services.ServiceProvider.RunPipeline[TRequest,TResult](String pipelineName, TRequest request)
at Sitecore.Commerce.Services.Products.ProductSynchronizationProvider.RunPipelineBody[TRequest,TResult](String pipelineName, TRequest request)
at Sitecore.Commerce.Services.Products.ProductSynchronizationProvider.SynchronizeProducts(SynchronizationRequest request)

There is an easy fix for this, simply enable your “Sitecore.Commerce.Products.Lucene.Index.Master.config” file and verify all of its settings.

IndexConfigSetup

Once completed, re-run the product synchronization tool and you can continue with the rest of your Sitecore Commerce Connect 7.2 installation.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

Blog at WordPress.com.

Up ↑

%d bloggers like this: